Back to overview
Degraded

Platform Unavailability

Jun 12, 2026 at 6:25pm UTC
Affected services
Personr Platform

Resolved
Jun 12, 2026 at 7:00pm UTC

We have identified the issue, and have rolled out a fix.

Created
Jun 12, 2026 at 6:25pm UTC

We are aware of an issue with some users unable to access the platform. We are investigating.